Jump to content



- - - - -

Whats the fastest you have ever driven?


17 replies to this topic

#1 fortfan

    Hall of Fame

  • Members
  • 1,537 posts

    Joined: 02-July 08
    Member No.: 3645

Posted 11 December 2013 - 02:16 PM

I had a 79 Camaro that I put a new engine in. It wasn't exactly "stock" and I could easily bury the speedometer that went to 130. So-I'd say around 130 was the fastest I have ever driven.

How fast would you drive if there was no speed limit?


#2 lepiota

    Hall of Fame

  • Members
  • 2,055 posts

    Joined: 31-August 09
    Member No.: 5013

Posted 11 December 2013 - 03:29 PM

I'd probably do 85 to 90 if there was no limit. Above that, it's easy to lose control if you hit a rise.

I'd then probably do 75 down Main St in that speedtrap call Cridersville, flipping the bird as I passed the police station.

#3 Colt45

    All State

  • Validating
  • 554 posts

    Joined: 27-December 11
    Member No.: 9167

Posted 11 December 2013 - 08:51 PM

The fastest I have ever went was about 115. Funny thing is that it was in a Honda Accord. A buddy of mine got his Mustang to about 135 awhile back.
I would consistently drive 75 to 80 if there was no limit.

Edited by Colt45, 11 December 2013 - 08:52 PM.


#4 ADog

    Stinkys Legend

  • Members
  • 7,742 posts

    Joined: 05-March 06
    Member No.: 614
  • Location:Bulldog Country

Posted 11 December 2013 - 08:54 PM

Was on Autobahn once in Germany and ran 200 kph (aprox 125 mph) and was passed like I was not moving

#5 MCguy

    All State

  • Members
  • 906 posts

    Joined: 04-January 06
    Member No.: 103
  • Location:Miller City

Posted 12 December 2013 - 02:14 AM

155 mph a couple times, and that's because the chip says that's fast enough and stopped the acceleration. I'll plead the fifth on where this occured. :)

#6 Mo-Problems

    All State

  • Members
  • 729 posts

    Joined: 14-July 08
    Member No.: 3654
  • Location:ohio

Posted 12 December 2013 - 09:22 AM

My '89 Chevy Beretta GT - 115. Decided that was stupid so I slowed her down.
Posted Image
I'd rather shower at Penn State than root for Michigan.

#7 labatts69

    Hall of Fame

  • Members
  • 1,948 posts

    Joined: 10-March 06
    Member No.: 695
  • Location:In a van down by the river

Posted 12 December 2013 - 08:27 PM

Mcguy, you must of had a car similar to mine. That was my top speed due to shut off also.
2010, 2011, 2012, & 2013 - Champion
Fantasy Baseball -RCBL

#8 charliesheen

    Hall of Fame

  • Members
  • 1,157 posts

    Joined: 03-June 11
    Member No.: 8871

Posted 12 December 2013 - 09:41 PM

Hey....I know a guy who once drove a Berrtta GT 115mph...he was following me.....were you heading East on 224 on a Friday about 20 years ago....lol

Edited by charliesheen, 12 December 2013 - 09:42 PM.


#9 Wilco98

    All State

  • Members
  • 867 posts

    Joined: 25-August 07
    Member No.: 2616
  • Location:Cavalier Country

Posted 13 December 2013 - 03:26 AM

Topped out at 180 in a friend's racecar a while back.
Coldwater Cavaliers--20 State Titles and Counting!!!!

#10 fortfan

    Hall of Fame

  • Members
  • 1,537 posts

    Joined: 02-July 08
    Member No.: 3645

Posted 13 December 2013 - 06:17 AM

Dang-my cars all shut down at around 106 now.


Ummmm - that's what I heard anyway…...

#11 Osu4me

    Hall of Fame

  • [M] Moderator
  • 4,171 posts

    Joined: 28-January 07
    Member No.: 1916
  • Location:Limaland

Posted 13 December 2013 - 10:51 AM

Fort Fan, I too (and I still have it) a 79 Camaro, In 79 I hit 125 out on the back roads in Utah. Not a car around so I let her rip....of course the guy with me was egging me on! I also have a 67 Camaro that I use to race against my brothers 74 Vette. I beat it every time!!!

#12 Week 10 All-American

    All State

  • Members
  • 692 posts

    Joined: 01-November 06
    Member No.: 1315

Posted 13 December 2013 - 05:28 PM

95-100... sadly in a minivan.

#13 LimaJock

    Hall of Fame

  • Members
  • 1,830 posts

    Joined: 30-December 06
    Member No.: 1673

Posted 15 December 2013 - 11:46 PM

View PostWeek 10 All-American, on 13 December 2013 - 05:28 PM, said:

95-100... sadly in a minivan.

Why bother going over 75 in a mini van. But for you, it was probably a big thrill. LJ
"I'm not always right, but I'm never wrong"

#14 Mo-Problems

    All State

  • Members
  • 729 posts

    Joined: 14-July 08
    Member No.: 3654
  • Location:ohio

Posted 16 December 2013 - 09:35 AM

View Postcharliesheen, on 12 December 2013 - 09:41 PM, said:

Hey....I know a guy who once drove a Berrtta GT 115mph...he was following me.....were you heading East on 224 on a Friday about 20 years ago....lol
Haha, wasn't me. I was 13 twenty years ago. For me, it was Amsterdam Rd in Auglaize County, New Bremen area, about 15 years ago. Middle of the day.
Posted Image
I'd rather shower at Penn State than root for Michigan.

#15 Week 10 All-American

    All State

  • Members
  • 692 posts

    Joined: 01-November 06
    Member No.: 1315

Posted 18 December 2013 - 07:45 PM

View PostLimaJock, on 15 December 2013 - 11:46 PM, said:

Why bother going over 75 in a mini van. But for you, it was probably a big thrill. LJ

Because I was in a hurry. Why bother going over 75 anytime? Geez....

#16 Osu4me

    Hall of Fame

  • [M] Moderator
  • 4,171 posts

    Joined: 28-January 07
    Member No.: 1916
  • Location:Limaland

Posted 22 December 2013 - 08:47 PM

View PostWeek 10 All-American, on 18 December 2013 - 07:45 PM, said:

Because I was in a hurry. Why bother going over 75 anytime? Geez....


and here I thought the speed limit was 75!! I have a bad habit of going 65 on SR 33 heading to the lake,
been pulled over 4 times this past summer but I have managed to charm my way out of the tickets!!
me-4 cops -0!! :pickles:

#17 bballcat

    Hall of Fame

  • Members
  • 1,254 posts

    Joined: 02-January 06
    Member No.: 46
  • Location:America's Heartland

Posted 24 December 2013 - 06:35 AM

Had a 1970 Torino that I buried the speedo a couple of times over 120. Felt like I was floating on air!

#18 Shannon

    Newbie

  • New Members
  • 9 posts

    Joined: 27-January 14
    Member No.: 9595

Posted 14 February 2014 - 10:59 PM

In HS a friend of mine had a '67 Chevelle with a 454 in it. We came back from Wauseon one night--running the back roads and hit 145 mph. The car was shaking so bad I thought it would disintegrate. I gave praise to the Lord when I got home.







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users